إضغط لتفاصيل الإعلانات



Results 1 to 2 of 2
Share
  1. #1
    Join Date
    Nov 2007
    Location
    Arab world!
    Posts
    6,169
    Blog Entries
    4
    Rep Power
    10

    Thumbs up VOIP QoS Example

    السلام عليكم و رحمة الله و بركاته

    مثال صغير لتطبيق ال QoS for VoIP

    PC--->IP phone--->Switch---->Router---->Internet



    على فرض عندنا 2 vlans

    VLAN 10 for data, and 20 for voice

    و نريد ضمان جودة الصوت و انتقاله بسرعة عبر الشبكة , و أعطائه الاولوية


    Configuring Switch:

    Interface FastEthernet0/1

    switchport trunk encapsulation dot1q
    switchport trunk native vlan 10
    switchport mode trunk
    switchport voice vlan 20
    spanning-tree portfast
    switchport priority extend cos 0
    speed auto
    شرح هذه الاوامر :
    هذه الاعدادات تسمح للصوت و الداتا بالمرور من نفس البورت و هم ب Valan مختلفة كما هو واضح ,
    Cisco IP phone يدعم بشكل تلقائي بروتوكولي 802.1q trunking و ال 802.1p COS tagging
    حيث سيقوم بعمل tagging للفويس ترافيك ب L2 COS 5 و يقوم أيضا بعمل L3 IP Precedence 5


    اما الامر :

    switchport priority extend cos 0
    لتأكد من الداتا الترافيك الصادرة عن ال PC سيتم إعادة تصنيفها و إعطائها L2 cos 0 و ذلك لأن ال PC متصل بالتلفون و نريد عزل تصنيف الداتا عن الفويس و عدم إعطاء نفس الأهمية لداتا بنفس قدر الفويس .



    الامر Speed auto مهم جدا جدا لأن cisco phone اعداداته الافتراضية هي auto-neqotation بالنسبة
    للسرعة و ال duplex

    فإذا كان البورت السويتش 100 و full-duplex عندها بشكل اتوماتيكي سيقوم ال cisco phone بجعل البورت المتصل به 100 و half-duplex عندها سيحصل بالتأكيد ما يسمى بال duplex mismatch

    الان إعداد الراوتر :

    ولا يجب علينا عمل 2 اكسيس ليست Extnded ACL اكسيس لست عملها هو ماتش الفويس ترافيك

    واحدة ل Voice RTP traffic
    ,
    و الثانية ل Voice signaling traffic


    signaling traffic For Skinny, H.323, MGCP:

    access-list 101 permit tcp any any range 2000 2002
    access-list 101 permit tcp any any eq 1720
    access-list 101 permit tcp any any range 11000 11999
    access-list 101 permit udp any any eq 2427

    RTP traffic

    access-list 102 permit udp any any range 32767

    الان نعمل class map لكل نوع ترافيك :


    class-map match-all voice-traffic
    match access-group 102

    class-map match-all voice-signaling
    match access-group 101
    الان نعمل policy map لكل كلاس انشأناه :


    policy-map qos-voice
    class voice-traffic
    priority 240

    class voice-signaling
    bandwidth 16

    class class-defult
    fair-queue
    هنا قمنا بإعطاء الفويس ترافيك 240 كيلوبايت من الباندويث و السيغنالينغ 16 kbps و باقي الترافيك الاخرى
    WFQ (Wighted fair queuing (



    اهم عملية بكل هذا هو حساب و تحديد كم نعطي للفويس ترافيك من الباندويث و هنا حسب كم مكالمة تتم بنفس الوقت راح اسمح بها و إذا سمحت على فرض ب 10 مكالمات بنفس الوقت هل راح يكفي الباندويث يلي انا محدده للباندويث ؟
    طبعا لازم أخذ بعين الاعتبار ال كوديك المستخدمة لضغط الصوت فلو كانت مثلا g711u فهي 80
    او مستعمل g729 فهي 11 , كل هذا يؤخذ بالحسبان , يعني ما نعطي باندويث بشكل اعتباطي !!

    أخيرا
    نطبق الان البوليسي على الانترفيس الواصل للانترنت و ليكن fa 0/0


    interface FastEthernet0/0
    service-policy output qos-voice

    اتمنى ان يكون قد أفادكم الموضوع
    تحياتي للجميع .
    منقول


  2. Facebook Comments - تعليقـك على الفيس بوك يسعدنا ويطور مجهوداتنـا


  3. Forum Ads:

  4. Forum Ads:

    اضفط هنا لمعرفة تفاصيل الإعلانات بالموقع


  5. Forum Ads:

    -->

  6. #2
    Join Date
    Jan 2008
    Location
    Egypt
    Posts
    3,946
    Blog Entries
    1
    Rep Power
    16

Similar Threads

  1. VOIP Network Engineer
    By eng_amy in forum Information Technology (IT)
    Replies: 0
    Last Post: 13-10-2012, 06:50 AM
  2. VOIP Engineer
    By IT Synergy in forum Information Technology (IT)
    Replies: 0
    Last Post: 03-05-2011, 02:39 PM
  3. VoIP Engineer
    By MONASAMIR in forum Networks
    Replies: 1
    Last Post: 05-09-2009, 02:12 PM
  4. voip
    By it man in forum Cisco Certifications
    Replies: 0
    Last Post: 22-06-2009, 12:55 PM
  5. VoIP books
    By Ismaeel in forum Networks
    Replies: 4
    Last Post: 12-11-2008, 12:41 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

أقسام المنتدى

الروابط النصية

تابع جروبنا على الفيس بوك

صفحة Egypt Engineers على الفيس بوك

تابعنا على linkedin

جروبنا على الياهو جروب